JHotDraw 6.0b1

org.jhotdraw.util
Interface VersionRequester

All Known Implementing Classes:
ConnectorApp, DrawApplet, DrawApplication, JavaDrawApp, JavaDrawApplet, MDI_DrawApplication, MiniMapApplication, NetApp, NothingApp, NothingApplet, PertApplet, PertApplication, SplitPaneDrawApplication, SVGDrawApp

public interface VersionRequester


Method Summary
 java.lang.String[] getRequiredVersions()
          Subclasses should override this method to specify to which versions of JHotDraw they are compatible.
 

Method Detail

getRequiredVersions

java.lang.String[] getRequiredVersions()
Subclasses should override this method to specify to which versions of JHotDraw they are compatible. A string array is returned so it is possible to specify several version numbers of JHotDraw to which the application is compatible with.

Returns:
all versions number of JHotDraw the application is compatible with.

JHotDraw 6.0b1